Help using --outputformat parameter

Sep 18, 2012 at 6:24 PM

I am having difficulty with using the --outputpath parameter in my script or via command line.  Essentially I want to have the file for each virtual machine be virtualmachinename.zip.  I have tried passing all permutations of {0}.zip and it won't take.  I usually get "Error: The folder "\\server\share" --outputformat {0}.zip" is not valid.  If I don't use --outputformat it works great, but with the date/time at the end which is unwanted.

Can someone please provide examples of using the --outputformat parameter?

 

Thanks,

Mark Ringo

Coordinator
Sep 18, 2012 at 6:30 PM

Hi Mark,

can you post the entire command line please?

Sep 18, 2012 at 6:55 PM

hvbackup.exe -a -o \\SERVERNAME\SHARENAME\DATE --outputformat "{0}.zip" 1> lastlog_out.txt 2> lastlog_err.txt

Jun 8, 2013 at 6:37 PM
hvbackup -n mx -o \xcopy\backup\hyperv\ -outputformat {0}.zip does not work either. Can we get a better set of documentation to clearly define what parameters are required? I can get hvbackup -a -o \destination_server\backup\hyperv\ to work but not if I want to backup a single VM. It always returns: "ERROR: The option --output is mandatory, you must define it." and yet I've clearly defined the -o command and --o isn't defined in the help screen (only one hyphen not 2).