This project is read-only.

Help! Error when backup.

Mar 4, 2013 at 6:52 AM
Edited Mar 4, 2013 at 12:32 PM
Hello. Please Help, cant backup the VMs, all or one.

.\hvbackup.exe : Error: The requested object was a duplicate.
At line:1 char:1
  • .\hvbackup.exe -l S-1C01 -o c:\111 1> lastlog_out.txt 2> lastlog_err.txt
  • ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    • CategoryInfo : NotSpecified: (Error: The requ...as a duplicate.:String) [], RemoteException
    • FullyQualifiedErrorId : NativeCommandError
at Alphaleonis.Win32.Vss.VssBackupComponents.AddToSnapshotSet(String volumeName, Guid providerId)
at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary2 vmNamesMapSubset, String backupOutputPath, String backupOutputFormat)
in c:\D
evel\HyperVBackup\HyperVBackup\BackupManager.cs:line 152
at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable
1 vmNames, VMNameType nameType, String backupOutputPath, String
backupOutputFormat, Boolean singleSnapshot) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line 87
at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\HyperVBackup\HyperVBackupApp\Program.cs:line 131
Mar 17, 2013 at 11:00 PM
I get the same. This is the command line I am using:

HVBackup --all --output C:\TestBackups --outputformat {0}_Backup.zip

1 backup completes as a ZIP including all parts (xml VM config and VHD/VHDX files)

Environment:
Windows Server 2012
Using a CSV on iSCSI
Mar 27, 2013 at 11:18 AM
Edited Mar 27, 2013 at 11:23 AM
Hey guys, first off can I say, great tool - there is nothing else like this freely available

This error seems to be a problem related to changes in Server 2012 as I am having issues too, here is the CMD output:


C:\HVBackup>HVBackup.exe -a -o "\192.168.0.12\Backups\VMs"
Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com

Backing up all VMs on this server
Initializing VSS
Error: The requested object was a duplicate.
at Alphaleonis.Win32.Vss.VssBackupComponents.AddToSnapshotSet(String volumeNa
me, Guid providerId)
at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary2 vmN
amesMapSubset, String backupOutputPath, String backupOutputFormat) in c:\Devel\H
yperVBackup\HyperVBackup\BackupManager.cs:line 152
at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable
1 vmName
s, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Bool
ean singleSnapshot) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line
87
at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\
HyperVBackup\HyperVBackupApp\Program.cs:line 131


If you guys need a guinea pig, I am happy to help out!

Environment:
Windows Server 2012 Datacenter w/.Net Framework installed
Using CSVs with Dell iSCSI San

Thanks, Rob


Note:
I have noticed that a backup is currently running successfully on the host which is currently the owner of the CSV - the other host has failed the backup with the error above. I also notice that the volume has not gone into redirected access mode.
Mar 29, 2013 at 8:53 PM
Encountered the same error on both nodes (Server 2012 Datacenter). Just ran on first node - error. Then moved VM to the other node, ran the backup from there - same error (lastlog_err.txt):
Error: The requested object was a duplicate.
   v Alphaleonis.Win32.Vss.VssBackupComponents.AddToSnapshotSet(String volumeName, Guid providerId)
   v Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary`2 vmNamesMapSubset, String backupOutputPath, String backupOutputFormat) v c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:ý dek 152
   v Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable`1 vmNames, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Boolean singleSnapshot) v c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:ý dek 87
   v Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) v c:\Devel\HyperVBackup\HyperVBackupApp\Program.cs:ý dek 131
Thanks,
Radek
May 14, 2013 at 10:05 AM
Jul 8, 2013 at 10:24 AM
Any news ? Solution ?
I´ve the same problem, overnight..
Oct 14, 2013 at 1:28 PM
Edited Oct 14, 2013 at 1:29 PM
Hi, ALL.
I had the same error im my clustered hyper-v environment.
I've found the VM which has a copy in cluster and in a hyper-v node.
As a decision i had to delete/recreate the problem VM in my cluster and it's ok now with backup.
Jun 8, 2014 at 11:52 AM
Jun 8, 2014 at 12:07 PM
NXNX wrote:
Hi, ALL.
I had the same error im my clustered hyper-v environment.
I've found the VM which has a copy in cluster and in a hyper-v node.
As a decision i had to delete/recreate the problem VM in my cluster and it's ok now with backup.
OK, you're right!

We must be sure that we don't really have duplicate VMs.
Look at Hyper-V manager mmc (not cluster)... If you have duplicate VMs, they are really duplicate. So, message say the true.

The right way to get existing VMs into cluster-pool-manager is running Hyper-V-add-role wizard and selecting VMs to get into cluster (not recreating into cluster-pool-manager from scratch)... otherwise, you'll get DUPLICATED VMs.
That's all.
Nov 5, 2014 at 7:08 AM
Hello, guys.
Catch this error "The requested object was a duplicate" on new, just created VM.
Any suggestions?

Info: tried this on Win2012R2 (2 nodes unified in cluster)

P.S. Sorry for my english