This project is read-only.

The requested object does not exist. Error

Jun 7, 2013 at 5:53 PM
This has been reported a couple of times before but I can't see a reply that has solved the issue.

SO

Any ideas on how to make the command below work - this is running on 2008R" and running two VM's one 2008R2 and one 2003


C:>c:\HVBackupProg\HVBackup.exe -a -o g:\backup
Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com

Backing up all VMs on this server
Initializing VSS

Starting snapshot set for:
Backup Using Child Partition Snapshot\NewShare

Volumes:
C:\
E:\
F:\
Error: The requested object does not exist.
at Alphaleonis.Win32.Vss.VssBackupComponents.GetSnapshotProperties(Guid snaps
hotId)
at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary2 vmN
amesMapSubset, String backupOutputPath, String backupOutputFormat) in c:\Devel\H
yperVBackup\HyperVBackup\BackupManager.cs:line 166
at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable
1 vmName
s, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Bool
ean singleSnapshot) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line
87
at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\
HyperVBackup\HyperVBackupApp\Program.cs:line 131
Jul 25, 2014 at 12:24 AM
For me the problem turned out to be that I had upgraded a hard drive to one with the newer 4K bytes per sector specification, which the Volume Shadow Copy Service, (that HVBackup uses,) doesn't support on Windows Server 2008 R2.

See the article here: http://support.microsoft.com/kb/2510009
Aug 25, 2014 at 3:27 AM
I get the same error on Windows 2012 R2 which does support 4K byte sectors.

Jemson, what did you do to resolve you backups?