1
Vote

Windows 2012 R2 Datacenter not working

description

Error: Ungltige Klasse 
   bei System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
   bei System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()
   bei Cloudbase.Titan.HyperV.Backup.BackupManager.GetVMNames(IEnumerable`1 vmNames, VMNameType nameType)
   bei Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable`1 vmNames, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Boolean singleSnapshot, Int32 compressionLevel)
   bei Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args)
Tested with Datacenter Preview Edition German Build 9431 /w Hyper-V role and .NET 3.5 feature installed.
Please fix it.
Thx!
David

comments

slepix wrote Jan 7, 2014 at 11:35 AM

I'm getting the same error on Windows Server 2K12 R2 Datacenter English

PS C:\Backup> .\HVBackup.exe -f list.txt -o \192.168.1.106\backups\Melita
Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com

Error: Invalid class
at System.Management.ManagementException.ThrowWithExtendedInfo(ManagementStatus errorCode)
at System.Management.ManagementObjectCollection.ManagementObjectEnumerator.MoveNext()
at Cloudbase.Titan.HyperV.Backup.BackupManager.GetVMNames(IEnumerable1 vmNames, VMNameType nameType) in c:\Devel\Hyp
erVBackup\HyperVBackup\BackupManager.cs:line 315
at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable
1 vmNames, VMNameType nameType, String backupOut
putPath, String backupOutputFormat, Boolean singleSnapshot) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line
76
at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\HyperVBackup\HyperVBackupApp\Program.cs:
line 131

Any chance for getting a fix? :)

alexp wrote Mar 14, 2014 at 9:39 PM

Hi, this new release should solve this issue:

https://hypervbackup.codeplex.com/releases/view/119695

Please let me know if it works for you.

Thanks,

Alessandro

davidb6 wrote Apr 29, 2014 at 1:03 PM

Ok thank you,
I've checked it, it works fine. In the meantime I had fixed it myself (workitem/8837). Glad that we can continue on our production systems!
David