2
Vote

Error: Entry "\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1\vhds\myvmname_29ABAA2F-C689-4156-92B2-DDA71F20404D-AutoRecovery.avhd" not found in snapshot

description

Hyper-V Server 2012 R2, fresh install, version 1.0.1.
Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com

Backing up all VMs on this server
Initializing VSS

Starting snapshot set for:
Online\myvmname

Volumes:
D:\
Error: Entry "\\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy1\vhds\myvmname_29ABAA2F-C689-4156-92B2-DDA71F20404D-AutoRecovery.avhd" not found in snapshot
   at Cloudbase.Titan.HyperV.Backup.BackupManager.AddPathToZip(String snapshotPath, Int32 volumePathLength, ZipFile zf, String vmPath, IList`1 streams)
   at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupFiles(String backupOutputPath, String backupOutputFormat, IList`1 components, IDictionary`2 volumeMap, IDictionary`2 snapshotVolumeMap, IDictionary`2 vmNamesMap, Int32 compressionLevel
)
   at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary`2 vmNamesMapSubset, String backupOutputPath, String backupOutputFormat, Int32 compressionLevel)
   at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable`1 vmNames, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Boolean singleSnapshot, Int32 compressionLevel)
   at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args)

comments

trltom wrote Aug 15, 2014 at 10:08 AM

Just build from source and it appears to work fine.

GMcDonnell wrote Dec 20, 2015 at 12:10 AM

I've found this happens when one or more of the virtual disks have less than ~5GB free space. That's the only time I've ever seen this error.

Typhus wrote Apr 8, 2016 at 11:01 AM

Hi trltom, what do you mean by "Just build from source"? I have three virtual machines and only one is getting this error.

trltom wrote Apr 11, 2016 at 12:17 PM

@Typhus

I downloaded the source code, compiled in Visual Studio, ran that version instead of the distributed download, and it worked on the same server which otherwise failed.

wrote Mar 15 at 3:35 PM

rxnetworkmobile wrote Oct 17 at 3:31 PM

Getting same error, Could you please share steps to recover from error ?
Would be highly appreciated !!