Unable to start HV Backup

Mar 13, 2012 at 5:38 PM

Hello,

 

I'm trying to backup a local VM to a local folder on the host and I get an error:

HVBackup.exe -l mdc-dc03 -o c:\temp

Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com

Error: Could not load file or assembly 'AlphaVSS.60.x86, Version=1.1.3000.1, Culture=neutral, PublicKeyToken=3033cf2dbd31cad3' or one of its dependencies. The system cannot find the file specified.   at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase,Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)   at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)   at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)   at System.Reflection.Assembly.Load(AssemblyName assemblyRef)   at Alphaleonis.Win32.Vss.VssUtils.LoadImplementation()   at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary`2 vmNamesMapSubset, String backupOutputPath, String backupOutputFormat)   at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable`1 vmNames, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Boolean singleSnapshot)   at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args)

 

Host is Windows 2008 R2 SP1 server with all updates.

Coordinator
Mar 29, 2012 at 2:02 PM

Hi ,

I added the missing assembly to the zip file available in the downloads.

Please let me know if this solves your issue. Being an x64 app it should look for the x64 version, so I'd like to investigate this issue.

 

Thanks,

Alessandro

Jun 1, 2012 at 8:15 PM

Hi friends I work in a goberment institution, and we install 8 Fisical servers in Windows 2008 R2 Server Core, with Hiper-V, 3 cluster configurations (2 servers each) and 2 indiviual servers, we try use the program in similar servers, I work in a first cluster and word excelent... but in the second cluster the program give  me the next message

Cloudbase HyperVBackup 1.0 beta1
Copyright (C) 2012 Cloudbase Solutions Srl
http://www.cloudbasesolutions.com
Error: Could not load file or assembly 'System.Core, Version=3.5.0.0, Culture=ne
utral, PublicKeyToken=b77a5c561934e089' or one of its dependencies. The system c
annot find the file specified.
   at Cloudbase.Titan.HyperV.Backup.CLI.Program.GetVMNames(Options options)
   at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\
HyperVBackup\HyperVBackupApp\Program.cs:line 113

I try run with only one VM (-l option) and with all (-o) and show me the same message

Thanks for your help...

Jun 1, 2012 at 9:52 PM

I go to check differens in the clusters and install the roles NETFx2 and NETFx3 and resolve the problem...

Thanks ...

Coordinator
Jun 1, 2012 at 11:42 PM

Yep, glad you solved it :-)

 

Alessandro Pilotti

MVP ASP.Net / IIS