Error with CSv

Jul 13, 2012 at 5:10 PM

Hi, I'm trying the product with a VM (Win 7) in 2008 R2 CSV

I obtain this error:

Initializing VSS

Starting snapshot set for:

Backup Using Child Partition Snapshot\WIN7-02

Volumes:

C:\ClusterStorage\Volume1\

Error: The requested object does not exist.

at Alphaleonis.Win32.Vss.VssBackupComponents.GetSnapshotProperties(Guid snapshotId)at Cloudbase.Titan.HyperV.Backup.BackupManager.BackupSubset(IDictionary`2 vmNamesMapSubset, String backupOutputPath, String backupOutputFormat) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line 166 at Cloudbase.Titan.HyperV.Backup.BackupManager.VSSBackup(IEnumerable`1 vmNames, VMNameType nameType, String backupOutputPath, String backupOutputFormat, Boolean singleSnapshot) in c:\Devel\HyperVBackup\HyperVBackup\BackupManager.cs:line87 at Cloudbase.Titan.HyperV.Backup.CLI.Program.Main(String[] args) in c:\Devel\HyperVBackup\HyperVBackupApp\Program.cs:line 131


Do you have some ideas ?

The product seems very interesting

Jul 13, 2012 at 5:16 PM

I noticed in Failover Cluster Manager -> Cluster Shared Volumes that the Disk (is CSV-01) is in Status "Online (Backup in Progress, Redirected Access"), maybe is doing something ?

Coordinator
Jul 13, 2012 at 6:10 PM

Can you please post the command line that you are using?

Also be sure that the VM that you are backing up is on the node on which you are running the backup tool. 

The CSV backup status will revert back to online in 20'

 

Thanks,

Alessandro 

Jul 16, 2012 at 8:38 AM

Thanks,

I used : .\HVBackup.exe -l WIN7-02 -o "\\10.10.2.35\backup\SRV-Backup\WIN7-02"

ITried also without quotes

I confirm that now CSV status is Online, but not backup are made

Coordinator
Jul 17, 2012 at 2:25 PM

By looking at the exception, VSS is not able to get info from the CSV volume. Are your hosts updated to SP1?

 

 

Jul 17, 2012 at 5:05 PM

yes, they are all SP1

Coordinator
Jul 17, 2012 at 5:36 PM

Ok. Does the VM have all the VHDs on the same CSV resource?

Jul 18, 2012 at 8:42 AM

On CSV there is only a test VM. This VM has only 1 .vhd. All the VM resources are in this CSV

 

Feb 25, 2013 at 7:01 AM
Hi.

I have the same problem when using HVBackup. We have a Hyper-V cluster environment with a DELL EQL storage.

In a non clustered environment all works perfect.

Could you please suggest what this can be? All the above doesn't help :|.

Thanks,
Sergiu